Be advised - Sendgrid is having a major outage.
Incident Report for brainCloud
Resolved
Sendgrid's mail service is working again, but in a degraded capacity. Once again, brainCloud is fine. We are going to close this incident from our side.

Update from Sendgrid - At this time, we are receiving and delivering mail as expected (NOT including Legacy or New Marketing Campaigns). Due to an issue in one of our data centers this morning, mail received from approximately 6:00AM MT - 6:15AM MT is still stuck in delivery. We are working to get those delayed messages delivered as quickly as possible. Customers may still see errors with non-mail send related API calls. Our app.sendgrid.com site and signup is still down. We sincerely apologize for the inconvenience and thank you for your patience. We will provide another update in 30 minutes or sooner as we get updates. Please reach out to our Support team at https://support.sendgrid.com with any questions.
Posted Jul 28, 2020 - 14:27 EDT
Update
Sendgrid is still having issues. They're update - We are still seeing mail and stat delays (including Legacy and New Marketing Campaigns). Mail is being accepted but could be stuck in queue. Users may be experiencing a higher volume of v2/v3 API call errors, especially 5xx errors around 9:45 AM MT. Our app.sendgrid.com site and signups are still down. We sincerely apologize for the inconvenience and thank you for your patience. Please reach out to our Support team at https://support.sendgrid.com with any questions. brainCloud continues to otherwise be fine.
Posted Jul 28, 2020 - 12:55 EDT
Monitoring
Starting at 6am MT, Sendgrid users may be experiencing issues regarding mail delays, v2/v3 API calls, and unavailability of their site. They are currently investigating. https://status.sendgrid.com. brainCloud itself is fine - but obviously any mail sent via our Sendgrid integrations will be affected...
Posted Jul 28, 2020 - 09:29 EDT